一个新的蓝牙高危漏洞被发现,或影响数百万台设备 - 嘶吼 RoarTalk – 回归最本质的信息安全,互联网安全新媒体,4hou.com

一个新的蓝牙高危漏洞被发现,或影响数百万台设备

TRex 漏洞 2018年7月26日发布

导语:一种新型蓝牙攻击技术已经被发现,CVE-2018-5383漏洞影响Apple,Broadcom,Intel和Qualcomm等主要供应商的固件或驱动程序。

一个高危的加密漏洞已经被发现影响了一些蓝牙实现设备,该漏洞允许未经身份验证的远程攻击者在物理上接近目标设备,从而拦截、监视或操纵交换的流量。

蓝牙漏洞CVE-2018-5383,影响来自一些主要供应商的固件或操作系统驱动程序,包括Apple、Broadcom、Intel和Qualcomm,而该漏洞对Google、Android和Linux的影响目前尚未确定。

该安全漏洞与两个蓝牙功能相关——操作系统软件中的安全连接配对的蓝牙低功耗(LE)实现,以及设备固件中的安全简单配对的BR / EDR实现。

工作原理

以色列理工学院的研究人员发现,蓝牙规范建议没有要求支持这两项功能的设备在安全配对期间验证通过无线方式接收的加密公钥。由于此规范是可选的,因此某些供应商的蓝牙产品支持这两个功能,不足以验证在Diffie-Hellman密钥交换期间用于生成公钥的椭圆曲线参数。在此情形下,配对过程中目标设备范围内的未经身份验证的远程攻击者,就可以启动一个中间人攻击,获取设备使用的加密密钥,允许暗中监听所谓的加密设备通信,窃取无线数据,并注入恶意软件。蓝牙技术联盟(SIG)该技术的维护者,评论该漏洞时所说 :

为了使攻击成功,攻击设备需要处于正在配对的两个存在漏洞的蓝牙设备的无线范围内。攻击设备需要通过阻止每次传输拦截公钥交换,对发送设备发送确认信息,然后在一个很短的时间窗口内将恶意数据包注入接收设备。然而,如果只有一个设备有漏洞,则攻击不会成功。

周一,CERT/CC还发布了安全公告 ,其中包括有关蓝牙漏洞和攻击方法的其他技术细节。根据CERT/CC,蓝牙利用了基于椭圆曲线Diffie-Hellman(ECDH)密钥交换实现加密通信的设备的配对机制。

ECDH密钥交换涉及私钥和公钥,且交换公钥以产生共享配对密钥。设备还必须同意所使用的椭圆曲线参数,但在一些实现中,这些参数未得到充分验证,允许无线范围内的远程攻击者“注入无效的公钥以很高概率确定会话密钥。”

阻止蓝牙攻击——安装补丁

为了解决这个问题,蓝牙技术联盟SIG现已更新蓝牙规范,要求产品将验证收到的公钥作为基于公钥的安全程序的一部分。此外,该组织还在其蓝牙资格认证流程中增加了对此漏洞的测试。CERT/CC表示固件或操作系统软件驱动程序都需要补丁,这些驱动程序应从受影响产品的供应商和开发人员处获得,并尽可能安装。更多内容,可参见: BlueBorne Attack Critical Bluetooth Attack Puts Billions of Devices at Risk of Hacking

Apple, Broadcom, Intel, Qualcomm受影响

到目前为止,Apple,Broadcom,Intel, Qualcomm已经发现其设备中包含受影响的蓝牙芯片组,而谷歌、Android和Linux尚未确认其各自产品中是否存在漏洞。Microsoft产品不受此影响。Apple和Intel已经针对此安全漏洞发布了补丁程序。Apple通过发布macOS High Sierra 10.13.5、iOS 11.4,watchOS 4.3.1和tvOS 11.4修复了此漏洞。

英特尔周一发布了软件和固件更新以修复蓝牙漏洞,告知用户高危漏洞会影响公司的双频无线AC、三频无线AC和无线AC产品系列。据Broadcom称,支持蓝牙2.1或更新技术的产品可能会受到报此漏洞的影响,但该芯片制造商声称已经为其OEM客户提供了修复服务,他们现在负责向最终用户提供这些产品。Qualcomm尚未发布关于漏洞的任何声明。蓝牙SIG表示,没有证据表明这个漏洞被恶意利用,并且没有发现任何实施攻击的设备开发出来,包括发现漏洞的研究人员。

本文翻译自:https://thehackernews.com/2018/07/bluetooth-hack-vulnerability.html?m=1如若转载,请注明原文地址: http://www.4hou.com/vulnerable/12763.html
点赞 5
  • 分享至
取消

感谢您的支持,我会继续努力的!

扫码支持

打开微信扫一扫后点击右上角即可分享哟

发表评论