CVE-2019-18634:Sudo Linux提权漏洞 - 嘶吼 RoarTalk – 回归最本质的信息安全,互联网安全新媒体,4hou.com

CVE-2019-18634:Sudo Linux提权漏洞

ang010ela 漏洞 2020-02-12 11:25:00
收藏

导语:​研究人员发现一个Sudo bug使非特权的Linux和macOS用户可以以root权限运行命令。

Sudo是macOS中预装的核心命令,也是每个Unix和基于Linux操作系统的最重要、最有力的工具。Sudo可以让不同的用户在无需切换环境的情况下以不同用户权限运行app或命令。

苹果安全研究人员Joe Vennix在sudo工具中发现一个漏洞,研究人员发现sudo工具在特定配置下运行低特权的用户或恶意程序在Linux或macOS系统上以管理员或root权限执行任意命令。

CVE-2019-18634漏洞分析

新发现的sudo漏洞CVE编号为CVE-2019-18634,影响sudo v1.8.26及更早版本,漏洞根源是一个栈溢出漏洞问题。

Vennix称该漏洞只有在sudoers配置文件的pwfeedback启用时才可以被利用,pwfeedback是提供一种视觉反馈的特征,即当用户在终端(terminal)输入口令时会显示*。但pwfeedback特征在sudo高版本和许多其他包中并不是默认启用的,只有Linux Mint、Elementary OS等一些Linux发行版中默认启用了该特征。

此外,当pwfeedback启用时,该漏洞可以被任意用户利用,包括没有sudo权限的用户。

Sudo开发人员Todd C. Miller解释说,当用户输入口令时该漏洞可以通过管道传递大量输入到sudo,因为攻击者有用于溢出缓冲区的数据的完全控制权限,因此漏洞被利用的可能性很高。

检查是否受影响

为了确定sudoers配置文件是否受影响,可以在Linux或macOS 终端中运行"sudo -l"命令来查看pwfeedback选项是否启用。如果启用,可以在sudoers配置文件中修改"Defaults pwfeedback"为"Defaults !pwfeedback"来禁用有漏洞的组件,以预防该权限提升漏洞被利用。

漏洞已修复

Vennix已经将该漏洞报告给sudo的维护人员,上周发布的sudo 1.8.31版本中修复了该漏洞。

Sudo 1.8.26中引入的EOF处理的变化,所以sudo v1.8.26 到1.8.30版本中的逻辑bug是不能被利用的。Apple公司上周也发布了macOS High Sierra 10.13.6, macOS Mojave 10.14.6, macOS Catalina 10.15.2的安全补丁。

本文翻译自:https://thehackernews.com/2020/02/sudo-linux-vulnerability.htm如若转载,请注明原文地址:
  • 分享至
取消

感谢您的支持,我会继续努力的!

扫码支持

打开微信扫一扫后点击右上角即可分享哟

发表评论