漏洞预警|Apache Kafka 拒绝服务漏洞 - 嘶吼 RoarTalk – 回归最本质的信息安全,互联网安全新媒体,4hou.com

漏洞预警|Apache Kafka 拒绝服务漏洞

棱镜七彩 行业 2022-09-22 14:02:34
收藏

导语:近日网上有关于开源项目Apache Kafka 拒绝服务漏洞,棱镜七彩威胁情报团队第一时间探测到,经分析研判,向全社会发起开源漏洞预警公告,提醒相关安全团队及时响应

近日网上有关于开源项目Apache Kafka 拒绝服务漏洞,棱镜七彩威胁情报团队第一时间探测到,经分析研判,向全社会发起开源漏洞预警公告,提醒相关安全团队及时响应。

项目介绍

Apache Kafka是一个高度可扩展的分布式消息队列。

项目主页

https://kafka.apache.org/

代码托管地址

https://github.com/apache/kafka

CVE编号

CVE-2022-34917

漏洞情况

Apache Kafka是一个高度可扩展的分布式消息队列。

在Apache Kafka受影响版本中,允许未经身份验证的恶意客户端在Broker上分配大量内存,这可能导致Broker内存不足进而导致拒绝服务。

攻击场景:

  • 没有身份验证的Kafka集群:任何能够与Broker建立网络连接的客户端都可能引发该问题。

  • 具有SASL身份验证的Kafka集群:任何能够与Broker建立网络连接而无需有效SASL凭据的客户端都可以触发问题。

  • 具有TLS身份验证的Kafka集群:只有能够通过TLS成功身份验证的客户端才能触发问题。

受影响的版本

org.apache.kafka:kafka_2.12@[3.1.0, 3.1.2)

org.apache.kafka:kafka_2.12@[3.2.0, 3.2.3)

org.apache.kafka:kafka_2.13@[3.2.0, 3.2.3)

org.apache.kafka:kafka_2.13@[3.1.0, 3.1.2)

org.apache.kafka:kafka_2.12@[3.0.0, 3.0.2)

org.apache.kafka:kafka_2.12@[2.8.0, 2.8.2)

org.apache.kafka:kafka_2.13@[3.0.0, 3.0.2)

org.apache.kafka:kafka_2.13@[2.8.0, 2.8.2)

修复方案

升级org.apache.kafka:kafka_2.13到 2.8.2 或 3.0.2 或 3.1.2 或 3.2.3 或更高版本

升级org.apache.kafka:kafka_2.12到 2.8.2 或 3.0.2 或 3.1.2 或 3.2.3 或更高版本

链接地址:

https://kafka.apache.org/cve-list

https://www.openwall.com/lists/oss-security/2022/09/19/3

https://nvd.nist.gov/vuln/detail/CVE-2022-34917

如若转载,请注明原文地址
  • 分享至
取消

感谢您的支持,我会继续努力的!

扫码支持

打开微信扫一扫后点击右上角即可分享哟

发表评论