Oracle WebLogic远程命令执行漏洞预警

知道创宇 漏洞 2019年4月22日发布
Favorite收藏

导语:知道创宇404实验室发出紧急漏洞预警,建议所有使用Oracle WebLogic的用户引起重视,注意防范。

2019年04月17日,国家信息安全漏洞共享平台(CNVD)官方发布安全公告称Oracle WebLogic wls9-async组件存在反序列化远程命令执行漏洞,攻击者可利用该漏洞,可在未授权的情况下远程执行命令。随后知道创宇404实验室启动应急流程,通过分析后复现了该漏洞并确定该漏洞影响启用了wls9_async_response.war及wls-wsat.war组件的所有Weblogic版本(包括最新版本),到本预警发布时,官方仍然没有发布对应修复补丁,属于“0 day安全”漏洞。

1.jpg

值得注意的是知道创宇旗下创宇盾监控发现该漏洞最早在4月17日存在漏洞扫描痕迹,另外从知道创宇ZoomEye网络空间搜索引擎总共检索到100671条历史数据,其中中国30,600条,主要分布在北京、广东、上海等省市。

2.png

知道创宇404实验室发出紧急漏洞预警,建议所有使用Oracle WebLogic的用户引起重视,注意防范,经过确定知道创宇旗下云安全防御产品“创宇盾”无需升级即可防御该漏洞。

临时解决方案:

方案1:找到并删除wls9_async_response.war、wls-wsat.war 并重启Weblogic服务

方案2:通过访问策略控制禁止 /_async/* 及 /wls-wsat/* (注意) 路径的URL访问。

知道创宇404实验室后续还将发布更多漏洞细节和漏洞应急方案,敬请关注。

如若转载,请注明原文地址: https://www.4hou.com/vulnerable/17531.html
点赞 0
  • 分享至
取消

感谢您的支持,我会继续努力的!

扫码支持

打开微信扫一扫后点击右上角即可分享哟

发表评论